EasyRoutes - EasyRoutes: Issue with cloud provider – Incident details
Get support
Get support
All systems operational
EasyRoutes: Issue with cloud provider
Resolved
Partial outage
Started 15 days ago
Lasted 31 minutes
Affected
EasyRoutes
Partial outage from 3:13 PM to 3:44 PM
Updates
Resolved
March 23, 2026 at 3:44 PM
Resolved
March 23, 2026 at 3:44 PM
This incident has been resolved.
Investigating
March 23, 2026 at 3:13 PM
Investigating
March 23, 2026 at 3:13 PM
We are currently experiencing an issue with our cloud provider.