Roundtrip - Issue with Google Cloud Services - Affected EasyRoutes, EasyRoutes Delivery Driver – Incident details

All systems operational

Issue with Google Cloud Services - Affected EasyRoutes, EasyRoutes Delivery Driver

Resolved
Major outage
Started 14 days agoLasted about 4 hours

Affected

EasyRoutes

Major outage from 6:00 PM to 6:50 PM, Operational from 6:50 PM to 8:13 PM, Partial outage from 8:13 PM to 10:00 PM

Shopify

Shopify → Shopify Admin

Shopify → Shopify API & Mobile

SMS Messaging

Twilio → SMS Messaging

Updates
  • Resolved
    Resolved
    Google have confirmed full service recovery for most of their affected services with some residual impact on remaining services that are still being resolved. We are no longer seeing elevated temporary issues related to Google services.
  • Monitoring
    Monitoring
    Google Cloud is still reporting issues. A low percentage of customers or drivers may experience temporary issues while Google Cloud continues their efforts on service recovery.
  • Resolved
    Resolved
    Issue has been resolved. System back to normal.
  • Monitoring
    Monitoring

    Google Cloud Services resumed normal operations and we are continuing to monitor.

  • Identified
    Identified
    Google Cloud Services is currently experiencing issues affecting many websites including EasyRoutes. We are continuing to monitor the issue.