Roundtrip - EasyRoutes: Issue with cloud provider – Incident details
Report an issue
Report an issue
Dark mode
All systems operational
EasyRoutes: Issue with cloud provider
Resolved
Partial outage
0
Started 14 days ago
Lasted less than a minute
Affected
EasyRoutes
Operational from 2:18 PM to 2:18 PM
Updates
Investigating
June 12, 2025 at 2:18 PM
Investigating
June 12, 2025 at 2:18 PM
We are currently experiencing an issue with our cloud provider.
Resolved
June 12, 2025 at 2:18 PM
Resolved
June 12, 2025 at 2:18 PM
This incident has been resolved.