Roundtrip - EasyRoutes: Issue with cloud provider – Incident details
Report an issue
Report an issue
Dark mode
All systems operational
EasyRoutes: Issue with cloud provider
Resolved
Partial outage
0
Started 26 days ago
Lasted 5 minutes
Affected
EasyRoutes
Partial outage from 8:15 PM to 8:20 PM
Updates
Resolved
May 30, 2025 at 8:20 PM
Resolved
May 30, 2025 at 8:20 PM
Issue has been resolved. System back to normal.
Investigating
May 30, 2025 at 8:15 PM
Investigating
May 30, 2025 at 8:15 PM
We are currently experiencing an issue with our cloud provider.