Roundtrip - EasyRoutes: Issue with cloud provider – Incident details
Report an issue
Report an issue
Twilio → SMS Messaging experiencing degraded performance
EasyRoutes: Issue with cloud provider
Resolved
Partial outage
Started 18 days ago
Lasted 5 minutes
Affected
EasyRoutes
Partial outage from 6:37 PM to 6:42 PM
Updates
Resolved
April 21, 2025 at 6:42 PM
Resolved
April 21, 2025 at 6:42 PM
Issue has been resolved. System back to normal.
Investigating
April 21, 2025 at 6:37 PM
Investigating
April 21, 2025 at 6:37 PM
We are currently experiencing an issue with our cloud provider.