All systems operational

EasyRoutes: Issues loading map

Resolved
Degraded performance
Started 4 months ago Lasted about 1 hour

Affected

EasyRoutes
Updates
  • Resolved
    Resolved
    This incident has been resolved.
  • Monitoring
    Monitoring

    EasyRoutes is fully operational with maps loading correctly. The team is continuing to monitor.

  • Investigating
    Investigating

    We are currently investigating reports of users being unable to load the Map within EasyRoutes.