Roundtrip - EasyRoutes: Temporary slow performance – Incident details

All systems operational

EasyRoutes: Temporary slow performance

Resolved
Under maintenance
Started 8 months agoLasted 14 minutes

Affected

EasyRoutes

Under maintenance from 4:43 PM to 4:58 PM

Updates
  • Resolved
    Resolved

    Issue has been resolved. System back to normal.

  • Investigating
    Investigating

    We are currently undergoing some routine maintenance. Some stores may see some temporarily slower performance. We expect this to resolve within the hour.