All systems operational

Routine maintenance

Completed
Scheduled for February 13, 2024 at 6:40 PM – 6:50 PM

Affects

EasyRoutes
Updates
  • Completed
    February 13, 2024 at 6:50 PM
    Completed
    February 13, 2024 at 6:50 PM

    Maintenance successfully completed.

  • In progress
    February 13, 2024 at 6:40 PM
    In progress
    February 13, 2024 at 6:40 PM
    We are planning for a scheduled maintenance during that time.