All systems operational

EasyRoutes: Issue with cloud provider

Resolved
Partial outage
Started 6 months ago Lasted 3 minutes

Affected

EasyRoutes
Updates
  • Resolved
    Resolved

    Issue has been resolved. System back to normal.

  • Investigating
    Investigating

    We are currently experiencing an issue with our cloud provider.