Roundtrip - EasyRoutes: Issue accessing EasyRoutes with free trials – Incident details

All systems operational

EasyRoutes: Issue accessing EasyRoutes with free trials

Resolved
Partial outage
Started almost 2 years agoLasted about 1 hour

Affected

EasyRoutes

Partial outage from 1:53 AM to 2:40 AM

Updates
  • Resolved
    Resolved

    Issue has been resolved. System back to normal.

  • Investigating
    Investigating

    A small amount of our free trial customers are experiencing trouble accessing EasyRoutes.