Roundtrip - Temporary Cloud Provider Outage – Incident details

All systems operational

Temporary Cloud Provider Outage

Resolved
Major outage
Started over 3 years agoLasted 35 minutes

Affected

EasyRoutes

Major outage from 11:30 AM to 12:05 PM

Updates
  • Resolved
    Resolved

    We have resolved an issue with our cloud provider causing users to not be able to access EasyRoutes. We are continuing to monitor this issue.

  • Identified
    Identified

    We have identified an issue with our cloud provider causing users to not be able to access EasyRoutes. We are continuing to work on a fix for this incident.