Roundtrip - EasyRoutes: Issue with cloud provider – Incident details

All systems operational

EasyRoutes: Issue with cloud provider

Resolved
Partial outage 40 %
Started 9 days agoLasted about 2 hours

Affected

EasyRoutes

Partial outage from 2:40 PM to 4:50 PM, Under maintenance from 4:50 PM to 4:55 PM, Partial outage from 4:55 PM to 5:03 PM

Updates
  • Resolved
    Resolved
    Issue has been resolved. System back to normal.
  • Update
    Update
    We implemented a fix and are currently monitoring the result.
  • Update
    Update
    Implementing a change to fix the underlying high database load issue.
  • Monitoring
    Monitoring
    Connections are stabilizing following our earlier mitigations. We continue to monitor performance closely.
  • Identified
    Identified
    We’ve identified high database load as the cause of ongoing connection issues. Our team is actively working on fixes and rolling out mitigations to reduce impact. Customers may continue to experience intermittent connection problems while these changes take effect.
  • Investigating
    Investigating
    We are currently experiencing an issue with our cloud provider.