Roundtrip - Some Users May Not Be Able to Access EasyRoutes – Incident details

All systems operational

Some Users May Not Be Able to Access EasyRoutes

Resolved
Degraded performance
Started over 2 years agoLasted 24 minutes

Affected

EasyRoutes

Degraded performance from 10:47 PM to 11:11 PM

Updates
  • Resolved
    Resolved

    Our team has identified the issue and have deployed on a fix that resolves this issue.

  • Identified
    Identified

    We have identified a temporary issue with our most recent update where certain accounts are not able to access EasyRoutes. Our team has identified the issue and are working on a fix that should resolve this. Deliveries are unaffected.